Office Therapy - Nullable Object Error Processing Claims
Reference Number: AA-00336 Views: 8740 Created: 03-29-2013 04:18 pm Last Updated: 06-28-2018 02:40 pm 0 Rating/ Voters


Problem:

When processing claims using the Claims Manager, an error is generated stating "System.InvalidOperationException: Nullable object must have a value."



If you are running Office Therapy version 11.5.6 and up, you will see something like this:




You will see a Message Box with a list of clients saying that the client is missing either the Diagnosis code or the Diagnosis code pointer. For each client in the list, make sure that a valid diagnosis is entered, and then validate the Diagnosis Pointer(s) as follows in the Resolution steps below.

Cause

This issue will occur when a client is charged, but the client does not have a valid ICD-9 diagnosis assigned at the time of the entry of the charge. This can happen if the client has a valid diagnosis set, but a date range was added to the diagnosis and the new charge/date of service is outside of the diagnosis date range.

In either event, Office Therapy will not be able to save a Diagnosis Pointer to the charge if there is no diagnosis to map it to.

Resolution:

You must first determine which client is generating this error. (For now, this is by process of elimination).

If you are running version 11.5.6 and up, Claims Manager will inform you of the name of the client(s) with the issue. However it will not list which specific date of service is missing a diagnosis pointer. For now, use process of elimination to determine which date of service is lacking the diagnosis pointer. 

Tip: If you know you have recently charged a new client before adding their Diagnosis, it will most likely be that client and first charge or few.

Once you have identified which client and associated date of service is failing to process, go to the client ledger and open the charge for that client. Go to the HCFA Details tab and visually confirm that a valid ICD-9 diagnosis is set and that the associated check box is checked. If all else looks good, click OK. Repeat this step for other clients and or charges as needed.

Important: Even though the check box may appear to be checked, this does not mean the diagnosis pointer existed yet. Office Therapy is designed to check the Diagnosis Pointer box automatically when creating a charge, but only if a valid ICD-9 diagnosis exists for the client at the time the charge was created, or if it is subsequently modified. For this reason, do not assume the checked box is saved and click cancel, always click OK. This will re-process the transaction.

 

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